Ducati Scrambler Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Its was a cool Sunday and was hitting the high way with the fam. Suddenly i look down at my dash to see how fast i was going and its blank(no lights , Nothing!!).Freaked out but trying to keep my cool i had 2 options risk pushing the bike all the way home or stop and try to fix what the problem was. I decided to pull up at the next safe point. Parked and turn off the ignition , immediately tried to turn it back on but no sign of life (except for the fuel pump sound). After a few mins of probing an older rider(rides the Ducati 969) mentions a Ducati would not start if the dash is off. That narrowed the issues and i found out it had a burnt fuse. Swapped the faulty fuse with the spares and the dash lite up like a Christmas tree.
 

·
Registered
Joined
·
1,530 Posts
Thanks for posting mide, I've made a note to myself. Glad you had some help on hand. Welcome to the forum!

Sarah
 

·
Registered
Joined
·
126 Posts
You fitted any mods to the bike? ie. tail tidy for example. I'm sure I read up on this issue where someone had fitted a tail tidy and nicked the reg plate light cable which kept popping this fuse.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
You fitted any mods to the bike? ie. tail tidy for example. I'm sure I read up on this issue where someone had fitted a tail tidy and nicked the reg plate light cable which kept popping this fuse.
Come to think about it . My tail tidy got nicked and the reg plate light cable broke i suspect this must have caused a short circuit of some sort. Would tape the reg plate cable ASAP.

Thanks
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
Thanks for posting mide, I've made a note to myself. Glad you had some help on hand. Welcome to the forum!

Sarah
Thanks Sarah,

Life on a Ducati is a constant learning curve. i think i finally figured the root problem from @Noddie's comment .

Regards
 

·
Registered
Joined
·
126 Posts
Come to think about it . My tail tidy got nicked and the reg plate light cable broke i suspect this must have caused a short circuit of some sort. Would tape the reg plate cable ASAP.

Thanks
1st thing I'd do is unplug the cable from the plug which on standard bike is directly under the seat at the space at the start of the swingarm (Not best at describing). This'll isolate the broken cable/light. Then you want to look at the cable cores for damage. You may need to cut the damaged parts out and then just put as much cable as you need to reach the tail tidy.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
1st thing I'd do is unplug the cable from the plug which on standard bike is directly under the seat at the space at the start of the swingarm (Not best at describing). This'll isolate the broken cable/light. Then you want to look at the cable cores for damage. You may need to cut the damaged parts out and then just put as much cable as you need to reach the tail tidy.
Just noticed my Trip count is Zero . Trip 1 , Trip 2 ..Total Trip = Zero ....can i fix this ?
 

·
Registered
Joined
·
100 Posts

·
Premium Member
Joined
·
2,624 Posts
I'm not sure either Mide, but I did read some where that it can take awhile for some idiot lights/faults to correct themselves , worth a try though ;)
 

·
Registered
Joined
·
24 Posts
Discussion Starter #14
I'm not sure either Mide, but I did read some where that it can take awhile for some idiot lights/faults to correct themselves , worth a try though ;)
I really hope it works ....as i constantly crack my head at guessing how much miles i have covered since getting the bike. **Fingers crossed**
 
1 - 14 of 14 Posts
Top