Ducati Scrambler Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello scrambler world,

I’m having problems turning on my Scrambler. Turning on the ignition key the headlight flashes but turns off. Dash doesn’t come on. Indicators, taillights and headlights not coming on either (bulbs ok). I checked the main fuses by the starter relay (2x 30amp fuses) and they seem fine (not blown). I’ve also checked the fuses under the fuse box and they’re not blown as well. I also checked the battery and its holding a steady 12-13 volts. If its not the battery, fuses, and starter relay...what could be the problem?
 

·
Registered
Joined
·
117 Posts
My understanding is it could still be a faulty cell in the battery even if showing 13v.

Maybe try hooking up to a friend's bike or car with jumper cables and see if the dash lights up that way. Try and get motorcycle jump cables if you can since they'll be smaller.

How old is your scrambler? There's a few reports round of her of batteries failing around 3-4 years in.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you for the reply!

My scrambler is a 2015. I suspected the battery too since I checked all the grounds, battery terminal connections, swapped out the ignition switch with a spare and checking all the fuses twice. I’m gonna do exactly that and pickup a battery from the dealership. I’ll report back with the findings.
 

·
Registered
Joined
·
894 Posts
I concur with the battery diagnosis, but I just thought I’d mention that the Scrambler ECU does some quirky things, well the 1100 does anyway.
I tried to fit aftermarket indicators, the ones that flow from side to side and the ECU didn’t like it so cut the power off to the indicators. Also I tried to fit a Healtech brake light modulator but a similar thing happened when trying to programme them the power was cut off. I suppose there are other thing happening in the Scramblers brain that we still need to learn about.
 
1 - 4 of 4 Posts
Top