Ducati Scrambler Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Ordered this item on August 17 for my Scrambler 1100 Sport, delivered September 13.
For $305 : received damaged part, missing LED light, no installation instructions, wrong electric diagram, poor design and fitting, and no customer support!

It is not plug and play as advertised, my bike is immobilized since almost 2 months now, waiting for the missing light, the replacement part (tail with no dent), the installation instructions and the right electric diagram.

Amadeus's Customer support is very sparse.

mugello_000.jpg
mugello_001.jpg
mugello_002.jpg
mugello_004.jpg
mugello_005.jpg
mugello_006.jpg
mugello_007.jpg
 

·
Registered
Joined
·
65 Posts
Oh jeez..
Wrong electric istructions, wrong size, seems to me like a 800's part sold as 1100's
And a bad customers support is slways a shame....
Good luck buddy
 

·
Registered
Joined
·
570 Posts
I've done bussiness with them once and everything was fine. It was a next oil cooler for my 1100 Scrambler and finish and fitment was good.

I hope you can work it out with them because this doesn't look good. Just keep trying some more wirh customer support ans give them a chance to set stings straight. I have to look into who my contact was over there. If I find the info I will report back to you.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I've done bussiness with them once and everything was fine. It was a next oil cooler foe my 1100 Scrambler and finish and fitting was good.

I hope you can work it out with them because this doesn't look good. Just keep trying some more wirh customer support ans give them a chance to set stings straight. I have to look into who my contact was over there. If I find the info I will report back to you.
Thanks Skippy! I'm in touch occasionally with Amadeus...
 

·
Registered
Joined
·
570 Posts
Thanks Skippy! I'm in touch occasionally with Amadeus...
My contact was Sittimat T. You can find him on Instagram and is also the contact that answered when I had contact threw [email protected].
When I look at there web site under search by bike there are 2 kits and the first kit says it wil fit all the 800 models and the 1100 wich I find pretty hard to believe. The second kit is 1100 only and this is probably what you ordered and what you should have gotten but I fear they sent the wrong item. If you can't find Sittimat threw Instagram maybe just ask for him trew the gmail link. Good luck, I hope things get solved for you.
1100
Screenshot_20191113-200556_Chrome.jpg
 

·
Registered
Joined
·
570 Posts
I don't understand one thing though, you say no led light/ missing led light but I can clearly see the black strip of leds with the cable with 4 leads laying in your first picture?
 

·
Registered
Joined
·
64 Posts
Big holiday this week in Thailand, no? Probably on the LaoKao by now.
No worry, next week maybe they call. back. TIT
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
No... but I have an update, I finally received only one part, the one that was damaged. Thank you Mugello, but at this pace it will take 6 months before I got everything you promised and before I can ride my bike... Still waiting for the license frame support with the correct measures, the correct electric schematics and the installation instructions.

43954
 
1 - 10 of 10 Posts
Top