Ducati Scrambler Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi all,
Went to check on the Scrambler today as it’s going to a new home and needed to remove a battery tender.
Did that (which I’ve done on several bikes before) only now when I go to start the bike the dash is either blank or will intermittently show different figures on the lcd screen. Backlight / surrounding dash lights / headlights / brake lights all fine and bikes starts no problem.
Tested the bike two weeks ago and all fine - haven’t been out since due to lockdown so bike has not budged!

Any ideas? Local Ducati dealer is closed today and 220km away.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #2 ·
I’ve checked fuses and they seem fine.
swapped in a different one for dash to make sure and same issue.
All I can think is fault with the unit itself or cabling somewhere along the line.
I removed the dash and completely dry / clean inside it.
Removed all fuses again under the seat and issue persists.
 

·
Registered
Joined
·
164 Posts
When you say blank do you mean the odometer is just dashes?
I had an issue where the bike stalled (in the rain) and the dash lost the KM count - everything else worked fine - trip counter continued to count KM's, but the total travel was gone.
had to take it back to the dealer who needed a code from Factory to reset.
It's just happened again - cruising along changing down and the bike lost power, came back when I let clutch out and the dash was blank again - I'm just riding it around now.
Most likely dealer will tell me ai need a new dash.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Not as extreme as that - bike and all other functions work fine. Just no characters appear so no symbols, digits etc. The LCD panel itself isn’t dead as characters will flash up intermittently but never the full thing.
Just like the image below.
46701


46702
 
1 - 6 of 6 Posts
Top