Ducati Scrambler Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
764 Posts
Discussion Starter · #1 · (Edited)
On Thursday I went to take the bike out of the garage and when I tried to kick up the side stand the whole thing moved backwards, bracket and all. The forward screw holding the bracket to the crankcase had fallen out so that it pivoted around the rear screw. I suspect but can't be certain that they hadn't been tightened properly by the dealer when warranty work was carried out last year. Anyway I fitted another M10 screw from my stock and thought that was that, until I started the bike and engaged gear. The engine cut out and a SD.STAND error showed in the dash instead of the mileage. Bugger.
I had a look and sure enough the wires had been torn right out of the sidestand switch, I don't know why I didn't notice when I replaced the screw?
The good news though was that I was able to repair it. The wire actually has a plug-in connector to the switch. I was able to take it apart, solder the wires to the terminals and fit it back into the switch and it all works again as good as new.
Here is a picture of a broken switch I had off an ST4s which is the same.
 

·
Registered
Joined
·
1,530 Posts
Glad you were able to fix that on the spot, Derek. Has the picture posted for you? I just see an X here.

Sarah
 

·
Registered
Joined
·
764 Posts
Discussion Starter · #3 ·
It's Google's file sharing that causes the picture problems. It should be seen by everyone but at the moment I think only I can see it. I've experienced this before. Hopefully it will sort it self.
 

·
Registered
Joined
·
1,231 Posts
It's Google's file sharing that causes the picture problems. It should be seen by everyone but at the moment I think only I can see it. I've experienced this before. Hopefully it will sort it self.
I can see it.
 

·
Registered
Joined
·
214 Posts
I can see it, too and will check my bracket screws this afternoon. It is very helpful to know of problems experienced by members.
 
1 - 7 of 7 Posts
Top